Print Page | Close Window

Asp.net Sayfam 2 Defa Çalışıyor

Printed From: C#nedir?com
Category: ASP.NET
Forum Name: ASP.NET
Forum Description: ASP.NET
URL: http://forum.csharpnedir.com/forum_posts.asp?TID=50046
Printed Date: 09 Aralık 2021 at 16:22
Software Version: Web Wiz Forums 11.01 - http://www.webwizforums.com


Topic: Asp.net Sayfam 2 Defa Çalışıyor
Posted By: SalmanArslan
Subject: Asp.net Sayfam 2 Defa Çalışıyor
Date Posted: 20 Ağustos 2012 at 09:15
Post kasmamak adına sorumu taylan arkadaşımızın somuş olduğu sorunun tam altına yazmıştım ama cevap alamadığım malesef belki gören olmadı diyerek sormu yeniliyorum bilen arkadaşlar ilgilenirse çok sevinirim.
http://www.csharpnedir.com/forum2/forum_posts.asp?TID=49948

Originally posted by <font color='#0000FF'>http://www.csharpnedir.com/forum2/member_profile.asp?PF=17383&FID=27</font> - SalmanArslan http://www.csharpnedir.com/forum2/member_profile.asp?PF=17383&FID=27 - SalmanArslan wrote:

]Gülme komşuna gelir başına derler ama taylan'a ben gülmedimki :)
aynı sorun bende'de oldu ve neden 2 defa tetiklendiğini bir türlü anlamdım
ama 2 defa tetiklenme olayı  routing  yaptıkdan sonra oldu

..<a href='User/"+Eval("yol")+"'>
---------------------------------------------
RouteTable.Routes.MapPageRoute("user", "User/{adi}", "~/user.aspx"
---------------------------------------------
string[] bilgi= DuubeBilisim.UserInfo(RouteData.Values["adi"].ToString()).Split('|');

user.aspx page load 2 defa tetikleniyor ama routing  kullanmadığımda 1 defa tetikleniyor arkadaşlar konuyu direk buraya açtım sorunumu nasıl halledebilirim acaba ??




-------------
04-07-2010 'da C Sharp'a Başladım.



Replies:
Posted By: SalmanArslan
Date Posted: 23 Ağustos 2012 at 13:59

Sorunu yarım'da olsa çözdüm sorun kullanmadığım bir .css dosyasını sildiğimde page load 1 defa tetiklendi ama buseferde  routing kullandığım sayfada

resimler gösterilmedi onların başına (/) Sılaş işaretini koyunca resimler eskisi gibi göründü fakad  en büyük sorun olarak örneğin

  <span id="sgecmesaj" class="bildiri" onclick=" return GeMesajBildirGoster(<%= Session["id"] %>)">
                        <%=  GelenBildirimAdeti.Split('|')[3] == "0" ? "" : GelenBildirimAdeti.Split('|')[3]%></span>
yukarıdaki span  tıkladığımda  GeMesajBildiriGoster() functionum hiç bir şekilde çalışmıyor normal sayfalarda çalışıyor  sanki yönlendirme yaptığım isimlerde böyle functionu arıyor gibi yada daha başka bir şey bu sorunu nasıl çözebilirim acaba  functionun sagına soluna bir şeymi yazmam gerekiyor değerli arkadaşlar ilgilenirseniz çok sevinirim.

-------------
04-07-2010 'da C Sharp'a Başladım.


Posted By: SalmanArslan
Date Posted: 23 Ağustos 2012 at 15:03
Konu çözüldü arayan mevlasınıda bulur neden 2 defa  postback olurmuş onuda buluyor :) herkese kolay gelsin.

-------------
04-07-2010 'da C Sharp'a Başladım.


Posted By: null29
Date Posted: 28 Ocak 2021 at 22:35
Soru çoktan sorulmuş ancak, vatandaş cevap yazmaya tenezzül etmemiş. akşam bu sorun karşıma çıktı. Anlamsız bir sorun, aşağıya cevabını yazıyorum.

sayfa loadında !page.ispostback kontrolünü yazıp yazmadığınızı, kontrol ediniz (muhtemelen yapmışındır)

bende sayfanın iki defa yüklenmesinin sebebi; bir image kontrolünde src="#" olarak verilmiş bundan kaynaklanıyormuş. O kadar aradım kodda bir sorun yok, htmlde de bunun sorun olacağı aklıma gelmemiş. Deneyerek buldum. Başkası aramasın. img lerde src değerine # yazmayın:)



Print Page | Close Window

Forum Software by Web Wiz Forums® version 11.01 - http://www.webwizforums.com
Copyright ©2001-2014 Web Wiz Ltd. - http://www.webwiz.co.uk