C#nedir?com Homepage
Forum Home Forum Home > ASP.NET > ASP.NET
  New Posts New Posts RSS Feed - Session Sorunu
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Session Sorunu

 Post Reply Post Reply
   

Author
Message Reverse Sort Order
nejate View Drop Down
Newbie
Newbie


Joined: 20 Mart 2020
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote nejate Quote  Post ReplyReply Direct Link To This Post Topic: Session Sorunu
    Posted: 20 Mart 2020 at 12:04
Merhaba,

aynı sorunu ben de yaşadım.uyguladığım çözümü anlatmaya çalışayım.

bu sorun Chrome un yayınladığı en son güncellemeden kaynaklanıyor. Cookielerin SameSite özelliğinin düzgün şekilde set edilmesini istiyor artık. bunun için IIS serverda en son .NET framework ünün yüklü olduğundan emin olmamız gerekiyor 4.7.2 veya üstü. ve çalışan siteların application poollarının .NET versiyonlarının v4.0. ve pipeline mode nun integrated olduğundan emin olun.

web.config dosyasında aşağıdaki satırların olduğundan emin olun. bunların hepsini yapınca server ı restart etmekte fayda var. umarım işinize yarar

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<system.web>
  <compilation targetFramework="4.8"/>
  <httpRuntime targetFramework="4.8"/>
</system.web>
 <system.web>
<httpCookies sameSite="None" httpOnlyCookies="true" requireSSL="true" />
</system.web>
<system.webServer>
  <security>
    <requestFiltering>
      <verbs>
        <add verb="TRACE" allowed="false" />
        <add verb="TRACK" allowed="false" />
      </verbs>
    </requestFiltering>
  </security>
</system.webServer>
 </configuration>
 


Back to Top
fizikhack77 View Drop Down
Newbie
Newbie


Joined: 18 Mart 2020
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote fizikhack77 Quote  Post ReplyReply Direct Link To This Post Posted: 18 Mart 2020 at 14:21
Merhaba sorunu çözebildinizmi.aynı SORUN BİZDE DE OLUŞTU
Back to Top
yunuskose View Drop Down
Groupie
Groupie


Joined: 19 Temmuz 2011
Location: Turkey
Status: Offline
Points: 76
Post Options Post Options   Thanks (0) Thanks(0)   Quote yunuskose Quote  Post ReplyReply Direct Link To This Post Posted: 12 Ocak 2020 at 20:53
Merhaba arkadaşlar;

Mvc razor yapısı ile e-ticaret sistemim var. Banka sanal pos ödemelerini ödeme sayfasından bankaya yönlenerek şifre girilip daha sonra sayfa siteye dönerek işlemleri gerçekleştriyoruz. Bu 3 yıldır doğru bir şekilde devam ediyordu. 

Ama gel görki son 1 aydır google chrome da bu işlem sorun oluşturmaktadır. Sistem bankaya sayfayı yönlendirip geri döndüğü zaman benim Session["xxx"] de ne var ne yok herşey gidiyor. Diğer tarayıcılarda bu sorun yok ama sadece google chrome da böyle bir sorun var ve çözemiyorum. 

Konuyla ilgili bilgi olan kişilerden yardım rica ediyorum. 
Antalya - ID Yazılım
Yazılım ve Veritabanı Uzmanı
yunus.kose@idyazilim.com
05355089134
Back to Top
 Post Reply Post Reply
  Share Topic   
   


Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.01
Copyright ©2001-2014 Web Wiz Ltd.